Akshay Mankar
8d707f9a53
Crashes immediately on hitting any route because vue js stuff is not compiled yet.
40 lines
1 KiB
Nix
40 lines
1 KiB
Nix
{pkgs, ...}: {
|
|
virtualisation.vmVariant = {
|
|
# following configuration is added only when building VM with build-vm
|
|
virtualisation = {
|
|
memorySize = 2048; # Use 2048MiB memory.
|
|
cores = 3;
|
|
};
|
|
};
|
|
|
|
users.users.root.openssh.authorizedKeys.keys = [
|
|
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMNeQYLFauAbzDyIbKC86NUh9yZfiyBm/BtIdkcpZnSU"
|
|
];
|
|
|
|
services.openssh.enable = true;
|
|
users.users.root.initialPassword = "root";
|
|
|
|
users.users.nixosvmtest.isSystemUser = true ;
|
|
users.users.nixosvmtest.initialPassword = "test";
|
|
users.users.nixosvmtest.group = "nixosvmtest";
|
|
users.groups.nixosvmtest = {};
|
|
|
|
services.loomio = {
|
|
enable = true;
|
|
encyrptedCredentials = ./loomio-credentials.yml.enc;
|
|
credentialEncryptionKeyFile = ./loomio-master.key;
|
|
};
|
|
|
|
services.postgresql = {
|
|
enable = true;
|
|
ensureDatabases = [ "loomio" ];
|
|
ensureUsers = [{
|
|
name = "loomio";
|
|
ensureDBOwnership = true;
|
|
ensureClauses.superuser = true;
|
|
}];
|
|
};
|
|
|
|
system.stateVersion = "23.11";
|
|
}
|