mirror of
https://git.sr.ht/~azikx/karbur
synced 2024-10-30 09:16:18 +00:00
28 lines
735 B
Nix
28 lines
735 B
Nix
{ lib, stdenv, fetchurl, autoPatchelfHook }:
|
|
let
|
|
version = "134";
|
|
hash = "sha256-WDygG9aGnD20nGxtG0t+T2KEwbJ+fZ0uRaCndirrsXI=";
|
|
in stdenv.mkDerivation {
|
|
name = "torrserver";
|
|
dontUnpack = true;
|
|
|
|
src = fetchurl {
|
|
url =
|
|
"https://github.com/YouROK/TorrServer/releases/download/MatriX.${version}/TorrServer-linux-amd64";
|
|
sha256 = "${hash}";
|
|
};
|
|
|
|
nativeBuildInputs = [ autoPatchelfHook ];
|
|
|
|
installPhase =
|
|
" mkdir -p $out/bin\n cp $src $out/bin/torrserver\n chmod +x $out/bin/torrserver\n";
|
|
|
|
meta = with lib; {
|
|
description = "Torrserver";
|
|
homepage = "https://github.com/YouROK/TorrServer";
|
|
license = licenses.unlicense;
|
|
meta.platforms = platforms.all;
|
|
mainProgram = "torrserver";
|
|
};
|
|
}
|