1
0
Fork 0
mirror of https://git.sr.ht/~azikx/karbur synced 2024-10-30 07:26:20 +00:00
karbur/host/system/hardware.nix
2024-10-26 18:23:16 +09:00

21 lines
422 B
Nix

{ pkgs, ... }: {
hardware = {
# OPENGL
graphics = { # GPU
enable = true;
enable32Bit = true;
extraPackages = with pkgs; [ amdvlk ];
extraPackages32 = with pkgs; [ driversi686Linux.amdvlk ];
};
# BLUETOOTH
bluetooth = {
enable = true;
powerOnBoot = true;
};
xone.enable = true;
system76.enableAll = true;
firmware = [ pkgs.linux-firmware ];
};
}