1
0
Fork 0
mirror of https://git.sr.ht/~azikx/karbur synced 2024-10-30 09:26:20 +00:00
karbur/modules(WIP)/host/hardware/cpu/default.nix
2024-10-26 18:23:33 +09:00

17 lines
358 B
Nix

{ lib, config, ... }:
with lib;
let cfg = config.module.hardware.cpu;
in {
options = { module.hardware.cpu.enable = mkEnableOption ""; };
config = mkIf cfg.enable {
hardware.cpu.amd = { # OPTIMIZATION FOR CPU
updateMicrocode =
lib.mkDefault config.hardware.enableRedistributableFirmware;
ryzen-smu.enable = true;
};
};
}