mirror of
https://git.sr.ht/~azikx/karbur
synced 2024-10-30 09:26:20 +00:00
17 lines
358 B
Nix
17 lines
358 B
Nix
{ lib, config, ... }:
|
|
|
|
with lib;
|
|
|
|
let cfg = config.module.hardware.cpu;
|
|
in {
|
|
options = { module.hardware.cpu.enable = mkEnableOption ""; };
|
|
|
|
config = mkIf cfg.enable {
|
|
hardware.cpu.amd = { # OPTIMIZATION FOR CPU
|
|
updateMicrocode =
|
|
lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
ryzen-smu.enable = true;
|
|
};
|
|
};
|
|
}
|