1
0
Fork 0
mirror of https://git.sr.ht/~azikx/karbur synced 2024-10-30 09:16:18 +00:00
karbur/modules(WIP)/host/services/getty/default.nix
2024-10-26 18:23:33 +09:00

17 lines
303 B
Nix

{ lib, config, username, ... }:
with lib;
let cfg = config.module.services.getty;
in {
options = { module.services.getty.enable = mkEnableOption ""; };
config = mkIf cfg.enable {
services.getty = {
autologinUser = username;
greetingLine = "Good day my lord ahhhh";
};
};
}