1
0
Fork 0
mirror of https://git.sr.ht/~azikx/wyswort synced 2024-10-30 07:26:20 +00:00
wyswort/host/misc/autocpu.nix
2024-10-15 22:18:01 +09:00

26 lines
705 B
Nix

{ inputs, ... }: {
imports = [ inputs.auto-cpufreq.nixosModules.default ];
programs.auto-cpufreq = { # CPU PERFMORMANCE
enable = true;
settings = {
charger = { # AC MODE
governor = "performance";
turbo = "auto";
energy_perf_bias = "balance_performance";
platform_profile = "balanced";
scaling_min_freq = 1400000;
scaling_max_freq = 4000000;
};
battery = { # BAT MODE
governor = "powersave";
turbo = "auto";
energy_perf_bias = "balance_power";
platform_profile = "low-power";
enable_thresholds = true;
# start_threshold = 20;
# stop_threshold = 80;
};
};
};
}