1
0
Fork 0
mirror of https://git.sr.ht/~azikx/wyswort synced 2024-10-30 09:06:19 +00:00
wyswort/modules/host/hardware/boot/default.nix
2024-10-26 22:44:55 +09:00

66 lines
1.5 KiB
Nix

{ lib, config, ... }:
with lib;
let cfg = config.module.hardware.boot;
in {
options = { module.hardware.boot = { enable = mkEnableOption ""; }; };
config = mkIf cfg.enable {
boot = { # ITSELF LOL
kernelPackages = pkgs.linuxPackages_zen;
kernelModules = [ "kvm-amd" ];
consoleLogLevel = 0;
kernelParams = [
"quiet"
"loglevel=3"
"nowatchdog"
"page_alloc.shuffle=1"
"threadirqs"
"split_lock_detect=off"
"pci=pcie_bus_perf"
"psmouse.synaptics_intertouch=0"
"rd.systemd.show_status=false"
];
loader = { # SYSTEMD BOOT AS DEFAULT
systemd-boot = {
enable = true;
configurationLimit = 4;
};
efi.canTouchEfiVariables = true;
timeout = 0; # TIMEOUT FOR LAUNCH
};
initrd = { # IDK
availableKernelModules = [
"nvme"
"xhci_pci"
"ahci"
"ohci_pci"
"ehci_pci"
"pata_atiixp"
"ums_realtek"
"sd_mod"
"sr_mod"
"sdhci_pci"
"usb_storage"
];
systemd.enable = true;
compressor = "zstd";
compressorArgs = [ "-9" ];
verbose = false;
};
plymouth = { # PLYMOUTH WITH NIXOS LOGO
enable = true;
logo =
"${pkgs.nixos-icons}/share/icons/hicolor/48x48/apps/nix-snowflake-white.png";
};
tmp.cleanOnBoot = true;
};
};
}