1
0
Fork 0
mirror of https://git.sr.ht/~azikx/wyswort synced 2024-10-30 09:06:19 +00:00
wyswort/modules/host/programs/hm/default.nix
2024-10-26 22:44:55 +09:00

18 lines
318 B
Nix

{ inputs, lib, config, ... }:
with lib;
let cfg = config.module.programs.hm;
in {
options = { module.programs.hm.enable = mkEnableOption ""; };
config = mkIf cfg.enable {
home-manager = {
useGlobalPkgs = true;
useUserPackages = true;
extraSpecialArgs = { inherit inputs; };
};
};
}