114 lines
3.4 KiB
Nix
114 lines
3.4 KiB
Nix
{
|
|
inputs = {
|
|
# Track channels with commits tested and built by hydra
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-24.05";
|
|
nixpkgs-unstable.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
|
|
home-manager.url = "github:nix-community/home-manager/release-24.05";
|
|
home-manager.inputs.nixpkgs.follows = "nixpkgs";
|
|
|
|
flake-parts.url = "github:hercules-ci/flake-parts";
|
|
|
|
disko.url = "github:nix-community/disko";
|
|
disko.inputs.nixpkgs.follows = "nixpkgs";
|
|
|
|
simple-nixos-mailserver.url = "gitlab:simple-nixos-mailserver/nixos-mailserver/nixos-24.05";
|
|
simple-nixos-mailserver.inputs.nixpkgs-24_05.follows = "nixpkgs";
|
|
simple-nixos-mailserver.inputs.nixpkgs.follows = "nixpkgs-unstable";
|
|
|
|
erpnext.url = "git+https://git.pub.solar/momo/erpnext-nix?ref=updates-2024-09";
|
|
|
|
invoiceplane-template.url = "git+https://git.pub.solar/momo/invoiceplane-templates.git";
|
|
invoiceplane-template.inputs.nixpkgs.follows = "nixpkgs";
|
|
invoiceplane-template.inputs.flake-parts.follows = "flake-parts";
|
|
};
|
|
|
|
outputs =
|
|
inputs@{ self, ... }:
|
|
inputs.flake-parts.lib.mkFlake { inherit inputs; } {
|
|
systems = [
|
|
"x86_64-linux"
|
|
"aarch64-linux"
|
|
];
|
|
|
|
imports = [
|
|
inputs.flake-parts.flakeModules.easyOverlay
|
|
./lib
|
|
./overlays
|
|
];
|
|
|
|
perSystem =
|
|
args@{
|
|
system,
|
|
pkgs,
|
|
config,
|
|
lib,
|
|
...
|
|
}:
|
|
{
|
|
packages = import ./pkgs args;
|
|
overlayAttrs = config.packages;
|
|
|
|
_module.args = {
|
|
inherit inputs;
|
|
pkgs = import inputs.nixpkgs { inherit system; };
|
|
unstable = import inputs.nixpkgs-unstable { inherit system; };
|
|
};
|
|
|
|
checks =
|
|
let
|
|
nixos-lib = import (inputs.nixpkgs + "/nixos/lib") { };
|
|
testDir = builtins.attrNames (builtins.readDir ./tests);
|
|
testFiles = builtins.filter (n: builtins.match "^.*.nix$" n != null) testDir;
|
|
in
|
|
builtins.listToAttrs (
|
|
map (x: {
|
|
name = "test-${lib.strings.removeSuffix ".nix" x}";
|
|
value = nixos-lib.runTest (
|
|
import (./tests + "/${x}") {
|
|
inherit self;
|
|
inherit pkgs;
|
|
inherit lib;
|
|
inherit config;
|
|
}
|
|
);
|
|
}) testFiles
|
|
);
|
|
|
|
devShells.default = pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
deploy-rs
|
|
nixpkgs-fmt
|
|
cachix
|
|
editorconfig-checker
|
|
nodePackages.prettier
|
|
nvfetcher
|
|
shellcheck
|
|
shfmt
|
|
treefmt
|
|
nixos-generators
|
|
opentofu
|
|
jq
|
|
];
|
|
};
|
|
|
|
devShells.ci = pkgs.mkShell { buildInputs = with pkgs; [ nodejs_22 ]; };
|
|
};
|
|
|
|
flake =
|
|
{
|
|
nixosModules = builtins.listToAttrs (
|
|
map (x: {
|
|
name = x;
|
|
value = import (./modules + "/${x}");
|
|
}) (builtins.attrNames (builtins.readDir ./modules))
|
|
);
|
|
|
|
checks = builtins.mapAttrs (
|
|
system: deployLib: deployLib.deployChecks self.deploy
|
|
) inputs.deploy-rs.lib;
|
|
|
|
formatter."x86_64-linux" = inputs.unstable.legacyPackages."x86_64-linux".nixfmt-rfc-style;
|
|
};
|
|
};
|
|
}
|