mirror of
https://git.sr.ht/~neverness/ultima
synced 2024-12-29 01:43:52 +00:00
32 lines
439 B
Nix
32 lines
439 B
Nix
{
|
|
x,
|
|
pkgs,
|
|
lib,
|
|
config,
|
|
...
|
|
}:
|
|
with lib;
|
|
with x;
|
|
let
|
|
cfg = config.module.hardware.bluetooth;
|
|
in
|
|
{
|
|
options = {
|
|
module.hardware.bluetooth = {
|
|
enable = mkBool;
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
hardware.bluetooth = True // {
|
|
# BLUETOOTH LOL
|
|
powerOnBoot = true;
|
|
};
|
|
environment.systemPackages = with pkgs; [
|
|
# TUI FOR BLUETOOTH
|
|
bluetuith
|
|
bluetooth_battery
|
|
];
|
|
};
|
|
}
|