1
0
Fork 0
mirror of https://git.sr.ht/~neverness/ultima synced 2024-12-29 02:43:53 +00:00
ultima/modules/nixos/hardware/sound/default.nix

38 lines
618 B
Nix

{
x,
inputs,
pkgs,
lib,
config,
...
}:
with lib;
with x;
let
cfg = config.module.hardware.sound;
in
{
options = {
module.hardware.sound = {
enable = mkBool;
};
};
imports = with inputs; [ gaming.nixosModules.pipewireLowLatency ];
config = mkIf cfg.enable {
environment.systemPackages = with pkgs; [ pulsemixer ];
security.rtkit = True;
services.pipewire = True // {
pulse = True;
wireplumber = True;
alsa = True // {
support32Bit = true;
};
lowLatency = True // {
quantum = 64;
rate = 48000;
};
};
};
}