mirror of
https://git.sr.ht/~neverness/ultima
synced 2024-12-29 02:03:54 +00:00
30 lines
424 B
Nix
30 lines
424 B
Nix
{
|
|
x,
|
|
lib,
|
|
config,
|
|
...
|
|
}:
|
|
with lib;
|
|
with x;
|
|
let
|
|
cfg = config.module.misc.locales;
|
|
in
|
|
{
|
|
options = {
|
|
module.misc.locales = {
|
|
enable = mkBool;
|
|
zone = mkOpt.str;
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
time.timeZone = cfg.zone; # TIME
|
|
services.chrony = True; # SYNC TIME
|
|
i18n = {
|
|
# LOCALE LANG
|
|
defaultLocale = "en_US.UTF-8";
|
|
supportedLocales = [ "all" ];
|
|
};
|
|
};
|
|
}
|