1
0
Fork 0
mirror of https://git.sr.ht/~neverness/ultima synced 2024-12-28 11:53:52 +00:00
ultima/modules/nixos/misc/nix.nix

40 lines
681 B
Nix

{
x,
pkgs,
lib,
...
}:
with lib;
with x;
{
nix = {
package = pkgs.nix;
settings = {
warn-dirty = false;
experimental-features = [
"nix-command"
"flakes"
];
trusted-users = [
"${userName}"
"@wheel"
];
substituters = [
"https://hyprland.cachix.org" # HYPRLAND
];
trusted-public-keys = [
"hyprland.cachix.org-1:a7pgxzMz7+chwVL3/pzj6jIBMioiJM7ypFP8PwtkuGc=" # HYPRLAND
];
};
};
nixpkgs = {
hostPlatform = mkDefault plfrm;
config = {
# NIXPKGS SETS
allowBroken = true;
allowUnfree = true;
};
};
system.stateVersion = ver;
}