mirror of
https://git.sr.ht/~neverness/ultima
synced 2024-12-29 01:43:52 +00:00
26 lines
283 B
Nix
26 lines
283 B
Nix
{
|
|
x,
|
|
lib,
|
|
config,
|
|
...
|
|
}:
|
|
with lib;
|
|
with x;
|
|
let
|
|
cfg = config.module.services.polkit;
|
|
in
|
|
{
|
|
options = {
|
|
module.services.polkit = {
|
|
enable = mkBool;
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
security = {
|
|
polkit = True;
|
|
soteria = True;
|
|
};
|
|
};
|
|
}
|