1
0
Fork 0
mirror of https://git.sr.ht/~neverness/ultima synced 2024-12-29 01:43:52 +00:00
ultima/modules/nixos/services/tailscale/default.nix

28 lines
346 B
Nix

{
x,
lib,
config,
...
}:
with lib;
with x;
let
cfg = config.module.services.tailscale;
in
{
options = {
module.services.tailscale = {
enable = mkBool;
};
};
config = mkIf cfg.enable {
services = {
tailscale = True // {
# OWN VPN NETWORK
useRoutingFeatures = "both";
};
};
};
}