mirror of
https://git.sr.ht/~neverness/ultima
synced 2024-12-28 11:13:52 +00:00
39 lines
673 B
Nix
39 lines
673 B
Nix
{
|
|
x,
|
|
lib,
|
|
config,
|
|
inputs,
|
|
...
|
|
}:
|
|
with lib;
|
|
with x;
|
|
let
|
|
cfg = config.module.themes.stylix;
|
|
wal = inputs.design;
|
|
in
|
|
{
|
|
options = {
|
|
module.themes.stylix = {
|
|
enable = mkBool;
|
|
theme = mkOpt.str;
|
|
};
|
|
};
|
|
|
|
imports = with inputs; [ stylix.nixosModules.stylix ];
|
|
config = mkIf cfg.enable {
|
|
stylix = True // {
|
|
# COLORIZE !!!
|
|
autoEnable = false;
|
|
base16Scheme = "${wal}/base16/${x.theme}.yaml";
|
|
targets = {
|
|
console = True; # TTY
|
|
chromium = True; # CHROMIUM LOL
|
|
fish = True; # SHELL
|
|
plymouth = True // {
|
|
logoAnimated = true;
|
|
}; # STARTING SCREEN
|
|
};
|
|
};
|
|
};
|
|
}
|