mirror of
https://git.sr.ht/~neverness/ultima
synced 2024-12-28 11:53:52 +00:00
35 lines
546 B
Nix
35 lines
546 B
Nix
{
|
|
x,
|
|
pkgs,
|
|
lib,
|
|
config,
|
|
...
|
|
}:
|
|
with lib;
|
|
with x;
|
|
let
|
|
cfg = config.module.virt.podman;
|
|
in
|
|
{
|
|
options = {
|
|
module.virt.podman = {
|
|
enable = mkBool;
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
environment.systemPackages = with pkgs; [ podman-compose ];
|
|
virtualisation = {
|
|
spiceUSBRedirection = True;
|
|
podman = True // {
|
|
dockerSocket = True;
|
|
dockerCompat = true;
|
|
autoPrune.enable = true;
|
|
defaultNetwork.settings = {
|
|
dns_enabled = true;
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|