infra-vintage/flake.nix

47 lines
1.7 KiB
Nix

{
description = "devs & ops environment for nix'ing with triton";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
nixpkgs-2205.url = "github:nixos/nixpkgs/nixos-22.05";
flake-utils.url = "github:numtide/flake-utils";
devshell.url = "github:numtide/devshell";
devshell.inputs.nixpkgs.follows = "nixpkgs";
tritonshell-module.url = "git+https://git.greenbaum.cloud/dev/tritonshell?ref=main";
tritonshell-module.inputs.devshell.follows = "devshell";
tritonshell-module.inputs.flake-utils.follows = "flake-utils";
tritonshell-module.inputs.nixpkgs.follows = "nixpkgs";
};
outputs = { self, flake-utils, devshell, tritonshell-module, nixpkgs, nixpkgs-2205 }:
flake-utils.lib.simpleFlake {
inherit self nixpkgs;
name = "infra-project";
preOverlays = [ devshell.overlays.default ];
shell = { pkgs }:
pkgs.devshell.mkShell {
imports = [ tritonshell-module.devshellModules.x86_64-linux.tritonshell ];
# Now the tritonshell environment nix module options are available
environment = {
enable = true;
# CUSTOMIZE if desired, default options are:
#cnsBaseDomain = "greenbaum.zone";
#dataCenters = [ "cgn-1" "lev-1" ];
#mantaDomain = "eu-central.manta.greenbaum.cloud";
#tritonApiDomain = "api.greenbaum.cloud";
};
# Add additional packages you'd like to be available in your devshell
# PATH here
devshell.packages = with pkgs; [
# used by triton-ansible-inventory
nodejs
nixpkgs-2205.legacyPackages.${pkgs.system}.terraform
];
};
};
}