Benjamin Bädorf
e8ad662631
This commit changes the file structure around, so that we have the following parts: `/modules` contains reusable logic blocks for hosts. `/hosts` contains host configurations. `/lib` contains nix library functions. `/overlays` contains overlay files. `/public-keys` contains all information regarding public keys. This change reduces the complexity of flake.nix, instead delegating this out to the `default.nix` files in the above directories.
19 lines
456 B
Nix
19 lines
456 B
Nix
{ flake, ... }: {
|
|
home-manager.users.${flake.self.username} = {
|
|
programs.git.enable = true;
|
|
programs.starship.enable = true;
|
|
programs.bash.enable = true;
|
|
programs.neovim = {
|
|
enable = true;
|
|
vimAlias = true;
|
|
viAlias = true;
|
|
defaultEditor = true;
|
|
# configure = {
|
|
# packages.myVimPackages = with pkgs.vimPlugins; {
|
|
# start = [vim-nix vim-surrund rainbow];
|
|
# };
|
|
# };
|
|
};
|
|
};
|
|
}
|