teutat3s
866700fdca
All checks were successful
Flake checks / Check (pull_request) Successful in 41m53s
Fix warnings: trace: evaluation warning: The option `services.forgejo.mailerPasswordFile' defined in `/nix/store/13vqhb5askjgi07wqwxawq4bdm7h0wc7-source/flake.nix, via option flake.nixosModules.forgejo' has been renamed to `services.forgejo.secrets.mailer.PASSWD'. trace: evaluation warning: Using `services.nextcloud.config.dbtableprefix` is deprecated. Fresh installations with this option set are not allowed anymore since v20. If you have an existing installation with a custom table prefix, make sure it is set correctly in `config.php` and remove the option from your NixOS config. Fix errors: - The option definition `services.matrix-sliding-sync' in `/nix/store/wgxgv8rjbd2nhf7y28kfzm4n6kz85dnq-source/flake.nix, via option flake.nixosModules.matrix' no longer has any effect; please remove it. The matrix-sliding-sync package has been removed, since matrix-synapse incorporated its functionality - The option `services.keycloak.settings.proxy' has been removed. Set `services.keycloak.settings.proxy-headers` in combination with other hostname options as needed instead. See [Proxy option removed](https://www.keycloak.org/docs/latest/upgrading/index.html#proxy-option-removed) for more information. error: The option `services.matrix-appservice-irc.settings.ircService.mediaProxy.publicUrl' was accessed but has no value defined. Try setting the option.
27 lines
676 B
Nix
27 lines
676 B
Nix
{ self, inputs, ... }:
|
|
{
|
|
flake = {
|
|
nixosModules = rec {
|
|
overlays = (
|
|
{ ... }:
|
|
{
|
|
nixpkgs.overlays = [
|
|
(
|
|
final: prev:
|
|
let
|
|
unstable = import inputs.unstable { system = prev.system; };
|
|
in
|
|
{
|
|
element-themes = prev.callPackage ./pkgs/element-themes { inherit (inputs) element-themes; };
|
|
element-stickerpicker = prev.callPackage ./pkgs/element-stickerpicker {
|
|
inherit (inputs) element-stickers maunium-stickerpicker;
|
|
};
|
|
}
|
|
)
|
|
];
|
|
}
|
|
);
|
|
};
|
|
};
|
|
}
|