39 lines
949 B
Nix
39 lines
949 B
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
pkgs,
|
||
modulesPath,
|
||
...
|
||
}: {
|
||
imports = [
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "ahci" "usbcore" "usbhid" "sd_mod"];
|
||
boot.initrd.kernelModules = ["dm-snapshot"];
|
||
boot.kernelModules = ["kvm-amd"];
|
||
boot.extraModulePackages = [];
|
||
|
||
fileSystems."/" = {
|
||
device = "/dev/disk/by-uuid/a3a74208-b244-4268-b374-e58265810fce";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
boot.initrd.luks.devices."cryptroot".device = "/dev/disk/by-uuid/afcde41f-9811-4ac8-bb7b-a683844acc5c";
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/12FD-62A8";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [
|
||
{
|
||
device = "/swapfile";
|
||
size = 68 * 1024; # 68 GB
|
||
}
|
||
];
|
||
}
|