Hibernation is now a core option: ``` pub-solar.core.hibernation.enable = true; ``` And there's a paranoia mode, that keeps the disk encrypted as much as possible by enabling hibernation and removing the options for sleep, screen locking. Idle locking now hibernates, and it does it on very short notice.
19 lines
483 B
Nix
19 lines
483 B
Nix
{ pkgs, ... }:
|
|
{
|
|
Unit = {
|
|
Description = "ydotool - Generic command-line automation tool (no X!)";
|
|
Documentation = [ "https://github.com/ReimuNotMoe/ydotool" ];
|
|
BindsTo = [ "sway-session.target" ];
|
|
After = [ "sway-session.target" ];
|
|
};
|
|
Service = {
|
|
Type = "simple";
|
|
ExecStart = "${pkgs.ydotool}/bin/ydotoold";
|
|
Restart = "on-failure";
|
|
RestartSec = "1";
|
|
TimeoutStopSec = "10";
|
|
};
|
|
Install = {
|
|
WantedBy = [ "sway-session.target" ];
|
|
};
|
|
}
|