70 lines
2.1 KiB
Nix
70 lines
2.1 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
pkgs,
|
||
modulesPath,
|
||
...
|
||
}: {
|
||
imports = [
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = ["xhci_pci" "usbhid" "usb_storage" "uas"];
|
||
boot.initrd.kernelModules = [];
|
||
boot.kernelModules = [];
|
||
boot.extraModulePackages = [];
|
||
|
||
#boot.kernelParams = [ "usb-storage.quirks=2109:0716:u,174c:55aa:u" ];
|
||
|
||
boot.kernelPackages = pkgs.linuxPackages_latest;
|
||
boot.supportedFilesystems = [];
|
||
|
||
boot.loader.grub = {
|
||
enable = true;
|
||
efiSupport = true;
|
||
efiInstallAsRemovable = true;
|
||
device = "nodev";
|
||
};
|
||
|
||
boot.loader.efi.canTouchEfiVariables = false;
|
||
|
||
boot.loader.systemd-boot.enable = false;
|
||
boot.loader.generic-extlinux-compatible.enable = false;
|
||
boot.loader.timeout = 0;
|
||
|
||
boot.initrd.luks.devices."cryptroot" = {
|
||
device = "/dev/disk/by-uuid/2538df0f-9d17-4651-a7ee-26d6f28e4e71";
|
||
keyFile = "/dev/disk/by-id/usb-SanDisk_Cruzer_Blade_04017028021722045451-0:0-part1";
|
||
fallbackToPassword = true;
|
||
bypassWorkqueues = true;
|
||
};
|
||
|
||
fileSystems."/" = {
|
||
device = "/dev/disk/by-label/root";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/5552-1B21";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
swapDevices = [
|
||
{device = "/dev/disk/by-label/swap";}
|
||
];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.eth0.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wlan0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "aarch64-linux";
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
|
||
}
|