50 lines
1.7 KiB
Nix
50 lines
1.7 KiB
Nix
# Edit this configuration file to define what should be installed on
|
||
# your system. Help is available in the configuration.nix(5) man page
|
||
# and in the NixOS manual (accessible by running ‘nixos-help’).
|
||
|
||
{ config, pkgs, lib, ... }:
|
||
|
||
{
|
||
imports =
|
||
[
|
||
# Include the results of the hardware scan.
|
||
./hardware-configuration.nix
|
||
];
|
||
|
||
# Set your time zone.
|
||
time.timeZone = "Europe/Berlin";
|
||
time.hardwareClockInLocalTime = true; # easiest quirk for windows time offset feature
|
||
|
||
# The global useDHCP flag is deprecated, therefore explicitly set to false here.
|
||
# Per-interface useDHCP will be mandatory in the future, so this generated config
|
||
# replicates the default behaviour.
|
||
networking.dhcpcd.wait = "background";
|
||
networking.useDHCP = false;
|
||
networking.interfaces.eno1 = {
|
||
useDHCP = true;
|
||
wakeOnLan = {
|
||
enable = true;
|
||
};
|
||
};
|
||
networking.networkmanager.enable = lib.mkForce false;
|
||
|
||
nixpkgs.config.allowUnsupportedSystem = true;
|
||
|
||
# List services that you want to enable:
|
||
|
||
# Open ports in the firewall.
|
||
networking.firewall.allowedTCPPorts = [ 22 ];
|
||
# networking.firewall.allowedUDPPorts = [ ... ];
|
||
# Or disable the firewall altogether.
|
||
# networking.firewall.enable = false;
|
||
|
||
# This value determines the NixOS release from which the default
|
||
# settings for stateful data, like file locations and database versions
|
||
# on your system were taken. It‘s perfectly fine and recommended to leave
|
||
# this value at the release version of the first install of this system.
|
||
# Before changing this value read the documentation for this option
|
||
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
|
||
system.stateVersion = "21.05"; # Did you read the comment?
|
||
}
|
||
|